floss:python:pip-pypi

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
floss:python:pip-pypi [2012/12/13 17:10]
villersd
floss:python:pip-pypi [2017/07/22 16:28] (Version actuelle)
villersd
Ligne 1: Ligne 1:
 ====== Installer facilement des modules python ====== ====== Installer facilement des modules python ======
 +
 +<note important>L'installation préalable de distributions complètes du type [[https://store.continuum.io/cshop/anaconda/|Anacaonda]], [[https://code.google.com/p/pythonxy/wiki/Downloads|Pythonxy]], Enthought ou ActivePython est préférable !
 +
 +Ces installations peuvent d'ailleurs l'installation des outils comme setuptools, distutils, pip,...
 +</note>
 +
  
 ===== Introduction ===== ===== Introduction =====
Ligne 12: Ligne 18:
   * [[http://cran.r-project.org/|R]],   * [[http://cran.r-project.org/|R]],
   * [[http://www.openjsan.org/|JavaScript]],   * [[http://www.openjsan.org/|JavaScript]],
-  * [[http://pear.php.net/channels/|php]],+  * [[http://pearL'installation préalable de distributions complètes du type [[https://code.google.com/p/pythonxy/wiki/Downloads|Pythonxy]], Enthought ou ActivePython est préférable ! 
 +  * [[https://pear.php.net/index.php|php]],
   * ...   * ...
  
-Ce grand répertoire se nomme [[http://pypi.python.org/pypi|PyPI]] (Python Package Index). Il reprend 27 889 paquets python (décembre 2012). Un programme nommé Pip permet de télécharger et ensuite installer des programmes ou librairies référencées dans le répertoire **Pypi**. Avant cela, il faut installer un programme dont le rôle est précisément d'installer des programmes. Il en existe en fait trois pour l'instant : +Ce grand répertoire se nomme [[http://pypi.python.org/pypi|PyPI]] (Python Package Index). Il reprend 112 860 paquets python (juillet 2017). Un programme nommé Pip permet de télécharger et ensuite installer des programmes ou librairies référencées dans le répertoire **Pypi**.
-  * [[http://pypi.python.org/pypi/setuptools/0.6c11|setuptools]], une solution qui n'est plus poursuivie, mais toujours fonctionnelle dans la plupart des cas (dont l'installation de Pip) +
-  * [[http://pypi.python.org/pypi/distribute/|Distribute]], un fork actuel fonctionnel de setuptools, pas forcément populaire, et qui est utilisé sans le dire dans les installations récentes de setuptools +
-  * [[http://pypi.python.org/pypi/Distutils2/|Distutils2]], une solution en cours de de finalisation, qui fonctionne avec la nouvelle branche (Python 3.3)+
  
-Une fois que ce premier programme d'installation sera opérationnella suite de la procédure consiste à l'utiliser (une fois), à l'aide de la commande //easy_install// pour installer Pip+Pour vérifier une installation existanten'hésitez pas à exécuter les commandes suivantes : 
 +  python --version 
 +  python2 --version 
 +  python3 --version 
 +  pip --version 
 +  pip2 --version 
 +  pip3 --version 
 +  virtualenv --version
  
 ==== Procédure sous Windows ==== ==== Procédure sous Windows ====
-  * Se rendre sur la page [[http://pypi.python.org/pypi/setuptools#downloads]] pour télécharger la version .exe exécutable de setuptools pour Python 2.7 (si c'est bien la version installée) 
-  * Exécuter le fichier téléchargé 
-  * Ajouter à la variable d'environnement PATH les éléments suivants : C:\Python27\;C:\Python27\Scripts (bien utiliser des ";" comme séparateur). Suivre les instructions disponible par exemple à la page [[http://www.java.com/fr/download/help/path.xml]] 
-  * Ouvrir une fenêtre de commandes, et taper easy_install pip 
- 
-Alternative "Distribute" : 
-  * Télécharger l'exécutable distribute [[http://python-distribute.org/distribute_setup.py|Distribute]] 
-  * Exécuter la commande "python.exe C:\Path\to\distribute_setup.py" 
-  * Mettre à jour la variable d'environnement PATH en ajoutant C:\Python27\;C:\Python27\Scripts 
-  * Ouvrir une fenêtre de commandes, et taper easy_install pip 
  
  
 ==== Procédure sous Linux ==== ==== Procédure sous Linux ====
 +
 +Sous Ubuntu, Debian et distributions dérivées, pour python (v2) et python3, au cas où pip ne serait pas installé :
 +<code>  sudo apt-get install python-pip python3-pip</code>
 +
 +Pour mettre à jour :
 +  sudo -H pip3 install --upgrade pip
 +  sudo -H pip2 install --upgrade pip
 +
 +
 +
 ====  Procédure sous Mac ==== ====  Procédure sous Mac ====
-À écrire.+À écrire, cf[[https://hackercodex.com/guide/python-development-environment-on-mac-osx/|ici]]
  
 ===== Utiliser Pip ===== ===== Utiliser Pip =====
-C'est donc Pip qui va être utilisé pour installer des programmes et librairies. Par exemple, pour installer vpython, taper dans une fenêtre de commande : <code> pip install numpy</code>+C'est donc Pip qui va être utilisé pour installer des programmes et librairies. Par exemple, pour installer matplotlib, taper dans une fenêtre de commande : <code> pip install matplotlib</code>
  
 +Attention, il est préférable d'utiliser les exécutables pour Windows proposés directement sur le site [[http://pypi.python.org/pypi|Pypi]], s'ils existent.
 +
 +<note tip>La plupart des librairies devraient être installées de manière locale, à l'exception de certaines, comme virtualenv. Donc sous GNU/Linux, il ne faut pas utiliser le "sudo".</note>
 +
 +Quelques commandes, remarques,... avec "nomlibrairie" comme nom de librairie, à remplacer  :
 +  * mise à jour à la dernière version : <code>pip install --upgrade nomlibrairie</code>
 +  * désinstaller : <code>pip uninstall nomlibrairie</code>
 +  * version de pip : <code>pip --version</code>
 +  * information à propos de la librairie : <code>pip show nomlibrairie</code>
 +  * génère une liste de librairies installées en "requirements" : <code>pip freeze > requirements.txt</code>
 +  * installe à partir d'une liste de "requirements" : <code>pip install -r requirements.txt</code>
 +  * lister les librairies : <code>pip list</code>
 +  * lister les librairies dépassées et les nouvelles versions : <code>pip list --outdated</code>
 +
 +Pour plus d'information, consulter le [[https://pip.pypa.io/en/latest/reference/|Reference guide]].
  
 ===== Virtualenv ===== ===== Virtualenv =====
 +venv, équivalent, est installé par défaut à partir de Python 3.3.
 +Après activation d'un environnement virtuel, son nom est indiqué entre parenthèses devant le prompt.
 +
 +Installation :
 +  sudo apt-get install virtualenv
 +  sudo apt install virtualenvwrapper
 +  echo "source /usr/share/virtualenvwrapper/virtualenvwrapper.sh" >> ~/.bashrc
 +Configuration :
 +  export WORKON_HOME=~/.virtualenvs
 +  mkdir $WORKON_HOME
 +  echo "export WORKON_HOME=$WORKON_HOME" >> ~/.bashrc
 +  echo "export PIP_VIRTUALENV_BASE=$WORKON_HOME" >> ~/.bashrc
 +  source ~/.bashrc
 +Utilisation (exemples) :
 +  mkvirtualenv --python=/usr/bin/python3 test
 +  deactivate
 +  workon test
 +  which python
 +  deactivate
 +  rmvirtualenv test
 +
 +refs :
 +  * [[https://askubuntu.com/questions/244641/how-to-set-up-and-use-a-virtual-python-environment-in-ubuntu]]
 +  * [[https://stackoverflow.com/questions/16123459/virtualenvwrapper-and-python-3]]
 +  * [[http://sametmax.com/les-environnement-virtuels-python-virtualenv-et-virtualenvwrapper/]]
 +  * [https://docs.python.org/3/tutorial/venv.html]
 +  * [[http://python-guide-pt-br.readthedocs.io/en/latest/dev/virtualenvs/]]
 +  * [[https://virtualenvwrapper.readthedocs.io/en/latest/]]
 +  * [[http://apprendre-python.com/page-virtualenv-python-environnement-virtuel]]
 +  * À tester : [[https://www.opendatascience.com/blog/setup-a-python-virtual-machine-with-ubuntu/]]
 +===== Problèmes particuliers =====
 +==== Upgrade de Matplotlib par pip sous Ubuntu 14.04 : ====
 +<note tip>Passer via sudo (sinon erreurs) </note>
 +  * [[https://mlbernauer.wordpress.com/2014/12/06/upgrading-from-matplotlib-1-3-1-to-1-4-1-in-ubuntu-14-04/]]
 +  * solution : 
 +    * sudo apt-get install libfreetype6-dev
 +    * sudo pip install --upgrade matplotlib
 +  * Résultats :
 +    * Successfully installed cycler-0.9.0 matplotlib-1.5.1 numpy-1.10.4 pyparsing-2.0.7 python-dateutil-2.4.2 pytz-2015.7 six-1.10.0
  
 ===== références ===== ===== références =====
Ligne 52: Ligne 117:
   * [[http://peak.telecommunity.com/DevCenter/EasyInstall]]   * [[http://peak.telecommunity.com/DevCenter/EasyInstall]]
   * [[http://www.pip-installer.org/en/1.0.1/index.html]]   * [[http://www.pip-installer.org/en/1.0.1/index.html]]
 +  * [[http://www.blog.pythonlibrary.org/2011/11/24/python-101-setting-up-python-on-windows/]]
 +  * [[http://python-packaging-user-guide.readthedocs.org/en/latest/installing/]]
 +  * [[https://pip.pypa.io/en/stable/|pip documentation]]
 +  * [[http://askubuntu.com/questions/431780/apt-get-install-vs-pip-install]]
 +  * [[http://kazhack.org/?post/2014/12/12/pip-gem-install-without-sudo]] (sudo or not sudo...)
 +  * [[http://www.dabapps.com/blog/introduction-to-pip-and-virtualenv-python/]] (intro pip & virtualenv)
 +  * virtualenv :
 +    * [[http://docs.python-guide.org/en/latest/dev/virtualenvs/]]
 +    * [[http://chrisstrelioff.ws/sandbox/2014/09/04/virtualenv_and_virtualenvwrapper_on_ubuntu_14_04.html]]
 +    * [[http://www.sitepoint.com/virtual-environments-python-made-easy/]]
 +
  • floss/python/pip-pypi.1355415045.txt.gz
  • Dernière modification: 2012/12/13 17:10
  • de villersd