Outils pour utilisateurs

Outils du site


floss:config_ubuntu_mate

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
floss:config_ubuntu_mate [2017/02/27 23:19]
villersd
floss:config_ubuntu_mate [2017/02/27 23:59] (Version actuelle)
villersd
Ligne 35: Ligne 35:
  
  
-  * sudo apt-get install synaptic geany+  * sudo apt-get install synaptic geany nautilus 
 +  * si caja → nautilus : [[https://​forum.manjaro.org/​t/​how-to-replace-caja-with-nautilus-in-manjaro-mate/​11932/​17]] : 
 +    * dconf editor -->​org/​mate/​desktop/​session/​required componenet - select file manager and write nautilus 
 +    * sudo pluma ~/​.local/​share/​applications/​mimeapps.list ?? 
 +      * goto line 43 inode/​directory=caja-file-handler.desktop;​ 
 +      * replace caja-file-handler.desktop with nautilus.desktop
  
    
Ligne 56: Ligne 61:
     * sudo apt-get install build-essential python3-dev g++ : outils nécessaires pour des compilations de libraire dont l'​installation n'est pas nécessaire (déjà OK)     * sudo apt-get install build-essential python3-dev g++ : outils nécessaires pour des compilations de libraire dont l'​installation n'est pas nécessaire (déjà OK)
     * sudo apt-get install libblas-dev liblapack-dev gfortran → dépendances nécessaires scipy     * sudo apt-get install libblas-dev liblapack-dev gfortran → dépendances nécessaires scipy
-    * sudo apt-get install libfreetype6-dev ​libpng-dev libjpeg8-dev → dépendances de matplotlib (seule libjpeg8-dev installée, le reste est satisfait)+    * sudo apt-get install libfreetype6-dev ​libpng12-dev libjpeg8-dev → dépendances de matplotlib (seule libjpeg8-dev installée, le reste est satisfait) 
 +    * sudo -H pip3 install --upgrade pip
     * python tools : utiliser "sudo pip3 install python3-tools",​ car "pip3 install"​ renvoie des messages d'​erreur (accès)     * python tools : utiliser "sudo pip3 install python3-tools",​ car "pip3 install"​ renvoie des messages d'​erreur (accès)
     * sudo pip3 install jupyter → (inclut ipython3) doc : [[http://​jupyter.readthedocs.org/​en/​latest/​index]]     * sudo pip3 install jupyter → (inclut ipython3) doc : [[http://​jupyter.readthedocs.org/​en/​latest/​index]]
     * sudo apt-get install python3-matplotlib (numpy OK)     * sudo apt-get install python3-matplotlib (numpy OK)
     * sudo apt-get install python3-scipy     * sudo apt-get install python3-scipy
-  * la plupart des autres paquets devraient être installés via pip +  * la plupart des autres paquets devraient être installés via pip3  
 + 
 + 
 + 
 +  * non installé (python 3.4.3-1) : Anaconda : [[http://​stackoverflow.com/​questions/​39371772/​how-to-install-anaconda-on-raspberry-pi-3-model-b]] 
 +    * [[https://​www.continuum.io/​content/​conda-support-raspberry-pi-2-and-power8-le]] 
 +    * cd Téléchargements 
 +    * wget http://​repo.continuum.io/​miniconda/​Miniconda3-latest-Linux-armv7l.sh 
 +    * sudo md5sum Miniconda3-latest-Linux-armv7l.sh 
 +    * sudo /bin/bash Miniconda3-latest-Linux-armv7l.sh 
 +  * ...
  
floss/config_ubuntu_mate.txt · Dernière modification: 2017/02/27 23:59 par villersd