Outils pour utilisateurs

Outils du site


floss:config_raspbian_rpi2

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

floss:config_raspbian_rpi2 [2016/03/06 10:22] (Version actuelle)
villersd créée
Ligne 1: Ligne 1:
 +====== Configurer un Raspberry Pi 2 sous Raspbian avec l'​interface graphique XFCE ======
 +Utilisation comme poste de travail, d'​apprentissage de GNU/Linux et de la programmation.
 +
 +Matériel nécessaire :
 +  * un Raspberry Pi version 2, avec une alimentation
 +  * clavier, souris USB
 +  * connexion filaire à internet
 +  * une carte micro-SD (8 ou 16 GB recommandés)
 +  * un écran (de PC ou téléviseur) avec connexion HDMI
 +
 +===== Installateur NOOBS =====
 +  * [[https://​www.raspberrypi.org/​help/​noobs-setup/​]] installation d'un OS (GNU/Linux raspbian) à l'aide du logiciel NOOBS
 +  * Sur un autre PC : télécharger NOOBS Lite 1.8 (29/​02/​2016) : [[https://​www.raspberrypi.org/​downloads/​noobs/​]]
 +  * préparation de la carte SD ou microSD : [[https://​www.raspberrypi.org/​documentation/​installation/​noobs.md]]
 +    * formatter la carte (FAT32)
 +    * décompresser le zip de NOOBS et copier le contenu du répertoire (NOOBS_lite_v1_8) sur la carte
 +  * placer la carte dans le Raspberry Pi, le brancher (y compris le réseau)
 +  * choisir l'​option Raspbian et démarrer l'​installation
 +
 +===== Configuration de base =====
 +  * sélectionner la langue (français ?) et le clavier (be ?)
 +  * raspi-config [[https://​www.raspberrypi.org/​documentation/​configuration/​raspi-config.md]] en ligne de commande (sudo raspi-config),​ ou à partir du menu preferences de l'​interface graphique LXDE :
 +    * boot to CLI (command line interface) (startx permet de démarrer l'​interface graphique)
 +    * memory GPU → 128 MB
 +    * language french, country Belgum, character set : utf-8
 +    * timezone Europe Brussels
 +    * keyboard Be
 +    * Wifi Belgium
 +  * Choisir l'​option de redémarrer pour valider
 +
 +===== Remplacement de l'​interface graphique LXDE par XFCE =====
 +  * réf : [[http://​linuxg.net/​how-to-properly-remove-lxde-and-install-xfce-on-raspbian-debian-for-raspberry-pi/​]]
 +  *  Utiliser une fenêtre de terminal
 +    * sudo apt-get install xfce4 xfce4-goodies (install xfce)
 +    * sudo apt-get remove lxappearance lxde lxde-* lxinput lxmenu-data lxpanel lxpolkit lxrandr lxsession* lxsession lxshortcut lxtask lxterminal (remove lxde)
 +    * sudo apt-get autoremove
 +    * sudo apt-get autoclean
 +    * sudo reboot
 +
 +===== Outils complémentaires =====
 +  * [[http://​www.codingepiphany.com/​2015/​03/​13/​the-raspberry-pi-2-desktop-experience/​]]
 +  * [[http://​computers.tutsplus.com/​articles/​how-to-install-alternative-web-browsers-on-the-raspberry-pi--mac-60717]]
 +    * sudo apt-get install iceweasel iceweasel-l10n-fr nautilus geany libreoffice libreoffice-l10n-fr
 +  * Bureau à distance : sudo apt-get install remmina ​
 +    * test UMONS - bureau à distance (ordinateur : rdsl.umons.ac.be,​ protocole : RDP, identifiant : nummat@umons.ac.be)
 +  * sudo apt-get update ... upgrade ... 
 +  * sudo apt-get install inkscape ​ → ok en fonctionnement (graphisme vectoriel)
 +
 +===== Environnement Python =====
 +  * Python3 : [[https://​www.raspberrypi.org/​documentation/​usage/​python/​]] python3 idle3 python3-pip ​ python3-venv ​ ( python3 idle3 python3-pip installé en standard)
 +    * sudo apt-get install python3-venv
 +    * sudo apt-get install build-essential python6-dev g++ : outils nécessaires pour des compilations de libraire dont l'​installation n'est pas nécessaire (déjà OK)
 +    * sudo apt-get install libblas-dev liblapack-dev gfortran → dépendances nécessaires scipy
 +    * sudo apt-get install libfreetype6-dev libpng-dev libjpeg8-dev → dépendances de matplotlib (seule libjpeg8-dev installée, le reste est satisfait)
 +    * python tools : utiliser "sudo pip3 install",​ car "pip3 install"​ renvoie des messages d'​erreur (accès)
 +    * sudo pip3 install jupyter → (inclut ipython3) doc : [[http://​jupyter.readthedocs.org/​en/​latest/​index]]
 +    * sudo apt-get install python3-matplotlib (numpy OK)
 +    * sudo apt-get install python3-scipy
 +  * la plupart des autres paquets devraient être installés via pip 
  
floss/config_raspbian_rpi2.txt · Dernière modification: 2016/03/06 10:22 par villersd